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Basic Text Editing
Infix enables you to edit text in a PDF document as if you were using a 
regular word processor.

Open the PDF document to be edited.

From the toolbar select the 
“Text Tool”.

Click the mouse on the text to be 
edited.

Edit the text - in this example the 
letter “r” has been added to “your”.

The text box is now too small to 
show all the text and needs to be 
expanded.

1

2

3

Continued...
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To reveal the missing text, resize the 
text box.

Drag the left & right resize handles 
outwards to make the box slightly 
wider.3

4

The text now fits on two lines as 
before.

Save the changes you have made to 
your document.

If you have the free version of Infix 
you will see this dialogue box.

You have the option to save your 
document with a watermark added to 
edited pages. The watermarks can be 
safely removed at a later date.

The second option allows you to save 
the document without a watermark 
for a small fee.

The third option activates your copy 
of Infix using the activation key 
supplied when you purchase the 
product. After activation watermarks 
are no longer added to documents. 

5

Continued from previous page
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Using Pay & Save
When you save your edited document using the free version of Infix, a 
watermark is added to each modified page.

You can avoid adding a watermark even when using the free version of Infix 
by using the Pay & Save option.

You will need internet access in order to use Pay & Save.

Choose Save... or Save As... from the 
File menu.

Press the Pay & Save button to save 
your document without a watermark.

1

If you don’t have a Pay & Save code 
already, press Buy a save code .

If you do have a code that you think 
may still be valid, press I know my 
code... and skip to step 5.

2

Continued...

Notes
• When adding watermarks, Infix changes the document’s security settings to 

stop editing by other programs.

• The Pay & Save feature is only available in Infix Standard Edition.
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On pressing the Buy... button your 
web browser will open and display 
the Pay & Save purchase page. 

From here you can purchase your Pay 
& Save code using a credit card via 
a totally secure on-line transaction 
system.

Your new code is then automatically 
registered in Iceni’s on-line database 
and a copy is emailed to you for your 
own records.

Once you have completed the 
purchase, switch back to Infix and 
press the Save Document button.

Infix will connect to the on-line Pay 
& Save database to verify your recent 
purchase, then save the document 
without a watermark.

3

4

If you already have a Pay & Save code 
from a previous purchase you may be 
able to reuse it.

When you buy your Pay & Save codes 
you can specify how many ‘saves’ 
to incorporate into the code. So for 
example, if you previously bought a 
code for 5 saves and you have used 
only 3 of them so far, your code 
could be used 2 more times before it 
expires.

5

Continued from previous page
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Activating Infix
Most editions of Infix will add watermarks to saved documents unless you 
activate the software using the code supplied when purchased.

Codes are usually provided as part of a purchase receipt email. If cannot find 
your code, please contact sales@iceni.com

Continued...

Choose Help->Buy/Activate...

1

2

If you have your activation key code 
to hand, press Activate...

If you have not yet purchased Infix, 
press Purchase. 

This will attempt to open the Infix 
web page using your system’s default 
web browser.

Once you have bought a license and 
have an activation key, press the 
Activate... button.
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Continued from previous page

On-line Activation

Your code may be a number or 
sequence of numbers and letters or 
your email address.

On-line activation is the quickest 
method. 

If your computer does not have an 
internet connection, uncheck this 
box.

Potential Problems

If you computer is behind a firewall or web access is blocked in some 
way, the activation may not succeed. If this is the case, follow the off-line 
activation instructions below.

Off-line Activation
Uncheck the Activate on-line checkbox to reveal the lower part of the 
dialogue box.

If you see this message after 
un-checking the Activate on-line 
checkbox, you need to obtain a 
different version of Infix.

As a security precaution, the demo 
versions of Infix available from Iceni’s 
web site cannot be activated off-line.

Use the download link provided in 
your emailed purchase receipt or 
contact sales@iceni.com to obtain 
a version which does allow off-line 
activation.

Continued...

3

4
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Continued from previous page

This is the code you should send to 
Iceni (your code will be different to 
that pictured) . The code changes 
every time you install Infix.

Press the Copy button to copy the 
code to the clipboard (to avoid 
copying it by hand)

Off-line activation is available in the 
version of Infix on your CDROM or 
from the web link included in your 
emailed purchase receipt.

Iceni will use the code you send to 
generate an off-line activation key- 
normally within 24 hours (except at 
weekends)

When you receive your off-line key 
enter it here.

The key will only work on the 
computer you used to generate the 
code. 

It will not work if you have re-installed 
Infix on that computer since you 
requested the off-line activation.

5

6
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Toolbars: Standard

Hand tool

Zoom in 
(Hold Ctrl to zoom out)

Fill / line colour for 
text and graphics

Open, save & print

Page View Buttons  
(Fit 100%, Fit Page, Fit Width)

Crop

Sticky Note

Hyperlink

Select Object

Rotate Object

Pipette tool

Toolbars: Editing

Text link tool

Text tool

Continued ...

Toolbars: Status

Go to first / last page

Go back / forwards 
(Hyperlink history)

Page number / total 

Zoom menu Page size

Previous Page Next Page 

* When viewing help topics in 
Infix, all toolbars are hidden. 

Turn them on again using the 
View->Toolbars menu.
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Notes
• Hold the Shift key down while using the circle or rectangle tools to draw a 

perfect circle (not an oval) or square.

• When using the pen tool hold the Shift key to draw lines at 0°, 45° & 90°

• Choose Object->Attributes... to change the fill or line colour of an object.

• Points in polygons and freehand paths cannot be modified after creation. 

Use the pen tool to draw 
straight-sided polygons.

Click the left button to add a new line 
to the polygon.

Double-click the left button to finish 
drawing.

Continued from previous page

Toolbars: Drawing
You can draw simple shapes such as circles, ovals, lines and rectangles using 
the tools on the “Drawing Toolbar”. Choose View->Toolbars->Drawing

Rectangle

PenLinePencil

Circle

Use the pencil tool to draw freehand 
shapes. 
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Infix Preferences
To modify certain features of Infix, choose File->Preferences...

Controls how the spell checker behaves and 
which dictionary is used.

The choice of spelling dictionary also controls 
hyphenation and justification.

It is very important that the language setting 
matches the predominant language of your 
document otherwise you may get poor 
results when fully justifying text.

The default language setting is English (US).

Controls hyphenation throughout 
all text in the document.

To control the hyphenation within 
a particular paragraph, select the 
Text Edit tool and begin editing 
the paragraph in question.

Right-click the mouse in the 
paragraph and choose Disable 
Hyphenation. (Infix Pro only)

Continued ...

Edited text can be highlighted in 
the chosen colour. This setting 
effects both on-screen display 
and printing. 

Text fields can be highlighted. 
This affects tab leader dots and 
user-defined text fields (Infix Pro 
only)

When enabled, all text boxes (even those not 
being edited) are outlined when the Text Tool 
is the current tool. 
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This is the name that will be 
stored in the Change Log 
generated whenever edits are 
made to a PDF.

When active, Infix saves a 
recovery backup of the current 
document every few minutes. 
A gap of around 10 minutes is 
reasonable.

When saving an edited PDF Infix stores 
additional information such as tab-stop 
positions, paragraph alignments, indents and 
margins etc. This makes it easier to edit the 
document using Infix or Infix Server but also 
increase the size of the PDF file.

Choose Never if you want to keep the PDF file 
as small as possible and do not need to keep 
the information.

Choose Always if the increase in file size is less 
important than ease of editing (or if you are 
making templates for Infix Server)

Choose Sometimes to let Infix decide. This is 
the default. 

Continued from previous page

When using File->Save... Infix can make an backup 
of the original file named “Backup of myfile.pdf”

This can be disabled for large files or when saving 
over networks.
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Select the ‘Selection Tool’ from 
the tool bar.

Click on a single object to select it.

If objects overlap, the top-most 
object is selected. Move or remove 
the top-most object to reveal and 
select objects it covers.

Selecting Objects

Drag out a box to select all objects 
touching the box.

Hold Shift to remove objects from the 
current selection.

Cut/Copy/Paste may be used on single 
objects or groups of objects.

Notes
• Press ‘Backspace’ or ‘Delete’ on your keyboard to delete selected objects.

• Click and drag to move the object or selection of objects to a new position. 

• Use the cursor keys to move selected objects by 1 point (1/
72

 inch). Hold the 
Shift key as well to move by 10 points.

• Copy/Paste of graphics between Infix & other applications is not supported.

• Infix cannot display transparent objects but will draw them as solid black 
shapes. This will not effect the PDF when viewed in other applications.

Some pages are littered with invisible objects making selections difficult. 
These objects can usually be safely removed without altering the 
appearance of the page.
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Stretching Objects
Selected objects can be stretched by dragging the handles on the sides or 
corners of the selection box. Alternatively, choose Object->Scale Selection... 
(Infix Pro only).

Select the object(s) to be 
stretched using the ‘Selection 
Tool’.

Drag one of the four side-handles or 
four corner-handles to stretch.

Selected objects will be stretched to 
fit the box you dragged out.

1

2

3

Notes
• Line widths are adjusted to take account of the scaling. 
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Scaling Objects (Isomorphic)
Objects can be scaled so that their aspect ratio is retained.

Select the objects to be scaled 
using the “Select Tool”.

Begin dragging one of the side or  
corner-handles. While dragging hold 
down the Shift key.

The drag box will grow by the same 
width and height as long as the Shift 
key remains held down.

Stop dragging to complete the scale.

1

2

3

Notes
• Line widths are adjusted to take account of the scaling. 



24 Editing Graphics & Images

Rotating Objects
Selected objects can be freely rotated by any angle. Alternatively, choose 
Object->Rotate Selection... (Infix Pro only)

Select the object(s) to be 
rotated using the “Selection 
Tool”.

Select the rotation tool.

Drag the selection’s outline to the 
desired orientation.

Hold down the Shift key while 
dragging to constrain rotation to 45˚ 
angles (0, 45 ,̊ 90 ,̊ 135˚ etc.)

Stop dragging to complete the 
rotation.

After rotation, the “Select Tool” will 
become active again. 

1

2

3

Continued...
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Changing Rotation Origin

Objects can be rotated around an arbitrary point.

Select the object(s) to be 
rotated then select the “Rotate 
Tool”.

Click the left mouse button to 
reposition the origin. 

Drag the selection’s outline to the 
desired orientation.

Hold down the Shift key while 
dragging to constrain rotation to 45˚ 
angles (0, 45 ,̊ 90 ,̊ 135˚ etc.)

Stop dragging to complete the 
rotation.

After rotation, the “Select Tool” will 
become active again. 

Rectangle’s origin has been moved to the 
centre of the circle1

2

3

Continued from previous page
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Changing Colours
All objects can have a line (or stroke) colour and a fill colour. 

You can choose new colours for either or make the line or fill invisible.

Circle has red line colour, yellow fill colour

Text has black fill colour and no line colour 
(this is common for text)

Text has no fill colour and red line colour

To change the colour of the selection 
press the “Fill Colour” / “Line Colour”. 
This displays the colour picker 
window.

1

2

3

Line colour

Fill colour

Short cuts for transparent, 
white & black

Press “Swatches...” to see a catalogue 
of all the colour currently in use in the 
document.

Switch fill/line colours
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Swatches Catalogue
The Swatches window shows all the colours used in a document. It can also 
be used to change the colour of selected objects.

1

2

Choose View->Swatches... to open the 
swatches catalogue.

There may be a short delay while the 
catalogue is built.

The catalogue shows the component 
values of each colour and (if 
available), the names of separation 
colours.

Double-click on a colour to change 
any selected objects.

CMYK, Gray and Separation colour 
values are shown as a percentages 
from 0 to 100.

RGB values range from 0 to 255

Choose between fill or line colour 
by clicking on the shape. 

Click on the black arrows to swap 
fill & line colours.

Notes
• You can restrict the colour available during editing to just those in the 

document or in a special hidden resource page. See User Restrictions for more 
information.

• The swatches catalogue is populated only when a document is opened.
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Next choose the Pipette tool 
from the toolbar.

Using the Object Select tool, 
select the object(s) whose 
colour you wish to change.

Copying Colours Between Objects
Use the Pipette tool to copy the colour from one object to another.

1

2

Click the Pipette on an object whose 
colour you want to copy.

2

The fill colour, line colour and line 
width of the chosen object is copied 
to the selected objects.
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Changing Line Width
You can alter the line with used to outline (or stroke) shapes and text.

1

2

Select the object(s) to be changed 
then choose Object->Attributes 
or press the attributes button 
in the toolbar.

Enter the line width required in points 
(1/

72
 inch). 

Entering 0 will produce the thinnest 
line possible.

To completely remove the outline, 
change the line colour to transparent.

An oval with a stroke width of 10.0 
points

An oval with a stroke width of 0.5 
points

Text with a line width of 0.75 points 
(text usually has a transparent outline)

Text with a line width of 2.0 points
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Aligning Objects
Choose the Selection Tool from 
the toolbar.

Select the objects to be aligned. 

Choose Object->Align->Top to align the 
tops of the objects together. 

All objects in the selection are aligned 
to the top-most object.

Notes

• The order in which you select items for alignment is not important.

• Aligning text blocks does not affect the paragraph alignment 
(justification) of within the text blocks.
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Importing Objects From Other Documents
To use objects (text, graphics & images) from one document in another, 
open both documents in Infix and use Copy/Paste to transfer between 
them.

1

3

2

Open one of your documents. Then 
use the File->Open In New Window... 
menu option to open the other 
document too.

Use the Edit->Copy and Edit->Paste 
menu items to copy objects from one 
document window to the other

Use Object->Group Selection to make 
the pasted objects easier to handle.

Scale and move the placed objects to 
fit the space required.
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Replacing Images
You can substitute an existing image for another loaded from disc. 
Supported image formats are JPEG, TIFF, PNG and BMP.

Choose the “Select Tool” from 
the toolbar.

Select the image to be replaced, then 
choose Edit->Replace Image...

You can also click the right mouse 
button to see a similar menu.

In this example a picture of a 
Volkswagen Beetle has replaced the 
old image.

The new image is placed inside the 
clipping mask (pink outline) used by 
the old image. 

The new image is automatically 
selected after being inserted.

Scale the new image by dragging one 
of the resize handles outwards. 

Hold the Shift key at the same time to 
ensure the aspect ratio is maintained.

2

3

1

Continued...
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The new image needs to be moved to 
the centre of the clip mask.

Drag it to its new position using the 
mouse or nudge it using the cursor 
keys (and Shift for larger steps).

The finished result after scaling and 
repositioning the new image.

5

4

Continued from previous page
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Inserting New Images
You can add any number of new images to your documents.

1

2

3

Choose Edit->Insert Image... then 
choose an image from the file 
selector.

Choose from JPEG, PNG, TIFF and BMP 
image formats.

The new image appears on screen. 
No clipping is applied, so the entire 
image is visible.

In this example, the new image has 
been moved and scaled.

You can apply a clipping mask to the 
image- see the following page.
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Removing Clipping Mask
Clipped objects can be moved independently of their clip masks. Objects 
can also be “popped” from their clip masks revealing the entire object.

The “Selection Tool” is active.

The car image (selected) is 
clipped by the oval clipping mask 
(shown in pink).

To remove the image from its clipping 
mask choose Object->Clipping Mask-
>Remove From Clip.

1

2

3

Note
• Clip masks only become visible (outlined in pink) when the “Selection Tool” 

is active.

The image is now fully visible. 

The clipping mask still exists and is 
shown in pink behind the image.
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Creating Clipping Masks
Any object or group of objects can have a clipping mask applied. The mask 
ensures only parts of the object are visible. This is often useful for images 
where you may want to hide the background for example.

3

2

1

In this example, we want to apply a 
clipping mask to the image of the car.

A shape is drawn using the “Pen 
Tool”. 

This shape will be used to make the 
clipping mask.

With the new shape selected, choose 
Object->Clipping Mask->Convert To Clip.

The shape will then become a pink 
outline.

Continued...
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4

5

6

The shape has now become a clipping 
mask.

It can still be moved, scaled and 
rotated but you can no longer change 
fill and line colours or line width.

Select the new clipping mask and all 
the objects you want to be masked 
by it.

Choose Object->Clipping Mask->Add To 
Clip.

Here, the image has now been added 
to the clipping mask. The parts of the 
image that are “outside” the mask are 
not displayed.

You can still move the mask and 
objects within it independently.

Notes
• Any empty clipping masks are automatically removed when a document is 

opened.

Continued from previous page
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On-Screen Display
1. Select the “Text Tool” from the tool bar.

2. Click on a block of text to begin editing.

The formatting bar and ruler will activate and a text box will be drawn 
around the text block being edited. 

Notes
• When you begin editing, spaces, paragraph marks and line-breaks will show 

up in pink. These will become invisible again when you finish editing.

• See Fonts In PDF for details of how certain fonts can make editing difficult.

• All text boxes are outlined with a dash pattern during text edit mode. This 
can be disabled from the preference dialogue box.

Ruler & MarginsFormatting toolbar

Space character  
(pink dot)

Paragraph End 
(Return)

Text box with 4 
resize handles

Line-break 
(Shift+Return)

Caret (black bar)  
Text is inserted here
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Creating New Text Boxes
New text can be added at any time by clicking and dragging out a new text 
box.

1

2

Select the “Text Tool” from the 
toolbar.

Click and drag to create a new text 
box.

After a short delay, the text box will 
be created ready for editing.

Choose the required font and size 
from the formatting bar before 
editing.
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Select the “Linked Text Tool” 
from the toolbar.

Click the mouse in the middle of each 
column you wish to link together.

The box will highlight and a number 
will be displayed in the middle. This 
number shows the order in which text 
will flow between the boxes.

If you click the same box twice it will 
be removed from the flow and the 
rest of the text boxes renumbered.

Keep adding further boxes by clicking 
the mouse. You can change pages 
and add text from different pages to 
the flow.

Editing Text Across Columns & Pages 
Link multiple text boxes into a chain and reflow the text across the whole 
chain.

1

2

3

Notes
• The text boxes will remain linked together even after you close and re-open 

the document.

When you are ready to begin 
editing select the “Text Tool” 
from the toolbar.
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Overset Text
When there is too much text to fit into a text box, the text that overflows is 
hidden and is called “overset” text.

To reveal the overset text, make the text box larger or connect it to another 
text box so the text can flow between them.

2

3

This text contains overset text. This is 
indicated by the small square in the 
bottom right of the frame. 

Resize the box to reveal the 
hidden text.

Instead of resizing the text box, 

(1) click on the overset symbol 
(2) drag-out a new text box.

The overset text will flow from the old text box into the new one. 
Continue linking new text boxes until all the text becomes visible.

1

Notes
• When saving documents, Infix always checks for overset text and reports the 

first occurrence found.
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Merging Text Boxes
Text boxes may be joined together when you need text to reflow as one.

1

2

3

4

In this example, Infix has split the text 
into three boxes. 

This will produce the wrong results 
when the text is reflowed.

While using the “Linked Text 
Tool” choose Text->Merge Boxes 
to join the three separate boxes 
into one.

Text will now flow as a single column 
and the results should look better.

Boxes in the same vertical row will be 
joined into one.
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Splitting Text Boxes
Text blocks can be split at paragraph boundaries. This can make editing 
large blocks of text faster and helps to avoid reflowing text that does not 
need it.

1

2

Use the “Linked Text Tool” to 
select the text box to be split.

The example shows a large block of 
text with complicating formatting.

To edit just the middle paragraph 
without reflowing any of the other 
text, the text box should be split.

Choose Text->Split Boxes.

The single box is split so that each 
paragraph becomes a box, not linked 
to any other. 

Although the new text boxes are not 
linked together, for clarity they have 
been linked together in this image to 
highlight the effect of splitting.

Continued...
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3

After splitting, Infix switches 
to the Text Tool automatically, 
ready for editing.

Continued from previous page
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Inserting Special Characters
Use the Character Palette dialogue to insert characters that are difficult to 
enter directly from the keyboard.

Click on some text to edit using the Text Edit tool.

Choose Text->Character Palette... 

Use the font menu to choose 
the required font from the 
document’s fonts and your 
computer’s system fonts. Next/Previous font

Click on a glyph to 
select it. 

Double-click to 
insert it into the PDF.

Poorly formed Type3 
fonts may display 
upside-down. Press 
Invert to rectify this.

Information about the selected glyph:

• name as used in the PDF (not always available) 
• official Unicode description 
• type of the font from which it comes
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Using Spell Check
After editing it is useful to check the spelling of any new text added. You can 
check the spelling of words in three ways:

• check just the words in a text selection 
• check words in active text blocks 
• check the whole document

The spell check dialogue box is accessed from Edit->Check Spelling... menu or 
by pressing the F7 function key.

The Spelling Dialogue Box

Double-click on a suggestion to make 
the change or single-click then press 
Change All.

Misspelled word is 
shown here. Type corrections here

Ignore this word and move onto next 
suspect

Ignore this word for the rest of the 
check.

Adds suspect word to user dictionary 
(See Appendix, “Custom Spelling 
Dictionaries”)

Replace suspect word with correctly 
spelled alternative.

Replace suspect word for correctly 
spelled alternative this time and every 
other time for this checking session.

Notes
• Be careful when changing text in paragraphs with unusual shapes (such as 

those that flow around graphics). When the paragraphs are reflowed, their 
layout may be lost. See Advanced Editing for methods of dealing with this.

• If the words shown in the Suspect: window seem garbled or include strange 
characters it indicates that the text cannot be extracted correctly from the 
document. This is caused by improper encoding of the document’s fonts 
and cannot be remedied with Infix.

Language used for spell check. Can be 
changed from File->Preferences... menu
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• You can edit the contents of the spelling dictionary - see Custom Spelling 
Dictionaries.

• If the replacement text cannot be rendered in the font used by the 
misspelled text, you will see the following warning:

• See Fonts In PDF for details of how fonts can effect the editing of text.

• Words that include numbers cannot be learnt by the spell checker. You can 
however, skip checking such words using the Ignore All button.

Spelling Preferences

Choose File->Preferences... or press Ctrl-K to open the Preferences dialogue 
box.

You can choose from North American, UK English, French, German, Italian or 
Spanish language dictionaries for use during spell checking.

You can also control checking of words with numbers and upper case words.

Choose the language required from the 
Language drop-down list.

Control the checking of UPPERCASE words 
and words that include numbers.
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Using the “Text Tool”, select the 
words you want to spell-check.

Then start the check from the  
Edit->Check Spelling... menu or press 
the F7 key.

Spell-Checking Text Selections

As each suspect word is displayed 
in the dialogue box, Infix will also 
highlight the word on the page.

You can type a new word into the 
Change To: box or select one of the 
words Infix has suggested then press 
Change.

When the selected text has been 
checked, you will be asked if you wish 
to check the rest of the document. 

Notes
• See Fonts In PDF for details of how fonts can effect the editing of text.

1

2

3
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Select the “Linked Text Tool” 
from the toolbar.

Select text boxes you wish to include 
in the spell check. See “Editing Linked 
Text Boxes” for details.

Select the “Text Tool” from the 
toolbar to begin editing the 
boxes.

Then start the check from the Edit-
>Check Spelling... menu or press the F7 
key.

As each suspect word is displayed 
in the dialogue box, Infix will also 
highlight the word on the page.

You can type a new word into the 
Change To: box or select one of the 
words Infix has suggested then press 
Change.

Spell-Checking Text Boxes

When all the text boxes in the current 
selection have been checked, you will 
be asked if you wish to check the rest 
of the document. 

Notes
• See Fonts In PDF for details of how fonts can effect the editing of text.

1

2

3
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Spell-Checking Documents

As each suspect word is found, Infix 
will highlight it, place an active text 
box around its text block and display 
the word in the dialogue box. 

You can type a new word into the 
Change To: box or select one of the 
words Infix has suggested then press 
Change.

With a document already open, 
choose Edit->Check Spelling... or press 
the F7 function key to begin checking 
the whole document.

Infix will tell you when the entire 
document has been checked. 

After checking, none of the text 
blocks that were made will remain 
active.

Notes
• See Fonts In PDF for details of how fonts can effect the editing of text.

1

2

3
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☞

☞

☞
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Formatting Toolbar
The formatting bar contains buttons for easy access to many of the most 
commonly used formatting functions.

All of the functions of the formatting bar (and more) are available in the Text 
menu.

Font name Font size Paragraph 
alignment

Superscript & 
Subscript

Line spacing

White portion shows 
width of text block

Left margin (triangle shape) 
Drag small square beneath triangle to 
move left & first-line margins together

Right margin

First-line indent

Notes
• You can change the units used for the ruler from the Preferences dialogue box. 

Press Ctrl-K or choose File->Preferences... from the main menu bar.

• You can “tear-off” the formatting toolbar and turn it into a floating window.

•  Both toolbar and ruler can be hidden using the View menu.

Underline

Ruler, Tabs & Margins Bar
The ruler displays a measure showing the width of the text box being 
edited. It also shows the setting for left, right and first-line indents. 
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Changing Font Size
You can alter the size of text in two ways: use the “Selection Tool” to scale it 
as you would scale any graphic object or use the “Text Tool” to set the size 
of the text font in points (1/

72
 inch).

Using “Text Tool”

1

2

Select the “Text Tool” and click 
on a block of text to begin 
editing.

Select some text by dragging the 
caret, double-clicking the mouse or 
using the cursor keys while holding 
down the Shift key.

From the font size drop-down menu 
choose a new size for the selection.

If the size you want is not in the menu 
enter the size in the drop-down 
menu’s edit box. You can also choose 
Text->Size->Other... from the main 
menu.

The text size has been changed and 
any affected text reflowed.

3
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Changing Fonts
You can change the font used to draw text to any one of the fonts used 
elsewhere in the document or to any TrueType font installed in your 
Windows system.

Choose one of the fonts listed in the 
drop-down menu in the formatting 
toolbar or from Text->Font in the main 
menu.

The menu lists all the fonts used in 
the document (in this case there are 
three) followed by all the TrueType 
fonts installed on your computer that 
could be used in your document.

1

Select the “Text Tool” and click 
on a block of text to begin 
editing.

Select some text by dragging the 
caret, double-clicking the mouse or 
using the cursor keys while holding 
down the Shift key.

1

2

Infix reports an error if the chosen 
font cannot represent all of the 
characters in your text selection.

If this happens, try a different font.
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Paragraph Alignment
Text in a paragraph can be left, centre or right aligned as well as fully 
justified. The alignment effects the entire paragraph.

Pressing an alignment button will 
cause the paragraph(s) to reflow.

Here “Left Justify” has been chosen.

Select the “Text Tool” and click 
in a text box to begin editing.

Place the caret inside a paragraph 
or select a block of text spanning 
multiple paragraphs.

The current alignment is shown 
by the alignment button that is 
depressed (in this case left).

left

centre

right

justify

Notes
• When a paragraph is fully justified, Infix may hyphenate words to improve 

layout. This hyphenation can be disabled from the Preferences dialogue box. 
Press Ctrl-K or choose File->Preferences... from the main menu bar.

• You can also control the vertical alignment of text within its box. See Vertical 
Text Alignment for details.

1

2
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To change the colour of the selection 
press the colour button on the main 
toolbar.

Choose the new colour for the 
selected text then press OK.

2

3

Select the “Text Tool” and click 
on a block of text to begin 
editing.

Select some text by dragging the 
caret, double-clicking the mouse or 
using the cursor keys while holding 
down the Shift key.

1

Changing Text Colours
There are two methods of changing text colour: use the “Selection Tool” and 
choose a new colour as you would for any other kind of object, or by using 
the “Text Select” tool.

Using “Text Select”
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Changing Line Spacing
From the toolbar you can change the paragraph line spacing to single, 11/

2
 

or double-spaced. Line spacing effects the entire paragraph.

Line spacing has been changed to 1.5 
and the paragraph has been reflowed.

(In this example, the text is now too 
long for the text box and the ‘overset’ 
symbol is displayed)

Select the “Text Tool” and click 
on a block of text to begin 
editing.

Place the caret inside a paragraph 
or select a block of text spanning 
multiple paragraphs.

single
1.5

double

Note
• For finer control over line spacing use the Line Spacing dialogue box.

• See Help->Keyboard Shortcuts... for alternative ways of changing line-spacing.

If the current line spacing is single, 
1.5 or double one of the line-spacing 
buttons in the formatting toolbar will 
be shown depressed.

1

2



 Formatting Text 59

Superscript & Subscript Characters
You can convert characters or words into superscripts and subscripts using 
the buttons available on the formatting toolbar.

superscript subscript

Select the “Text Tool” and click 
on a block of text to begin 
editing.

Select some text by dragging the 
caret, double-clicking the mouse or 
using the cursor keys while holding 
down the Shift key.

Notes
• If you change the font size of text that includes super/sub-scripts, Infix will 

try to maintain the relationship between the different sizes of text. 

Press the Superscript button to raise 
and shrink the text. Press the button 
again to return the text to normal.

Press the Subscript button to lower 
and shrink the text. Press the button 
again to return the text to normal.
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Underline 
You can underline a character or words using the Underline button available 
on the formatting toolbar.

Select some text, or move the caret 
into a word and press the underline 
button on the formatting toolbar.

For more control over the width, 
colour and position of the underline 
choose the Text->Underline Options... 
menu item.

Using the Underline Options dialogue 
box, you can change the colour of an 
underline.

Continued...
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Example Underline Effects

Offset to -20 points

Offset to 20 points

Width of 0 points (hairline)

Width of 15 points

Notes
• Text is always drawn after its underline decoration.

• Text is always drawn before its strikethrough decoration.

Continued from previous page
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Strikethrough
Strikethrough can be applied to any word or selection of words by choosing 
Text->Strikethrough Options... Unlike Underline, there is no button on the 
toolbar for strikethrough.

The simplest way to activate 
strikethrough is to click the Enable 
check box and press OK.

Strikethrough

Strikethrough

Strikethrough

Example Strikethrough Styles

Offset of -20 points

Offset of 40 points

Weight of 15 points
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Margins & Indents
You can control the left, right and first-line indents for paragraph text. These 
indents apply to the entire paragraph.

Select the “Text Tool” and click on a block of text to begin editing.

Place the caret inside a paragraph or select a block of text spanning 
multiple paragraphs.

To change a margin, drag the margin 
triangle to the position required. 

The picture shows the “First Line 
Indent” triangle being dragged.

As you drag the margin, a dotted line 
allows you to line-up the margin with 
other objects on the page.

White portions shows width 
of text block

Left margin (triangle shape) 
Drag small rectangle beneath triangle to 
move left & first-line margins together

Right margin

First-line indent

The first-line indent has been 
changed so that the paragraph starts 
with an indent.

Continued...
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Notes
• For finer control of indents especially for text that flows around shapes, see 

Advanced Editing.

To create a hanging indent as shown 
in image 2, move the left-indent 
inward without moving the first-line 
indent.

Ruler Units
You can change the ruler’s unit of measurement. Choose from Centimetres, 
Inches, Points and Picas via the “Preferences” dialogue box.

Choose File->Preferences... to change the 
ruler’s units.

1

2

This paragraph now has a hanging 
indent.

Continued from previous page
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☞
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Line Spacing
Use the “Line Spacing” dialogue box to set line spacing values other than 
Single, 1.5 and Double.

1

While in text edit mode, choose  
Text->Letter Spacing... from the main 
menu bar. 

The Letter Spacing dialogue box 
offers “At Least”, “Exactly” & “Multiple” 
spacing modes.

At Least

This paragraph shows the effect of 
the “At Least” mode in which you tell 
Infix the minimum gap between lines 
(measured in points).

To stop the “default” line (shown left) 
from colliding with the previous line, 
Infix has automatically increased its 
line spacing.

Exactly

This paragraph shows the effect of 
the “Exactly” setting in which you tell 
Infix the exact gap size between lines 
(measured in points). 

Infix has used exactly the same 
spacing for each line regardless of 
whether or not they collide.

Continued...
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Multiple

Use “Multiple” mode to specify gaps 
such as “2.5 lines” meaning that the 
gap will be at least 2.5 times the line 
height.

Setting multiples of 1, 1.5 or 2 is 
the same as pressing the single, 1.5 
or double spacing buttons on the 
formatting toolbar.

Continued from previous page
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Paragraph Spacing
You can create a gap between paragraphs in three ways:

1. Use the “Selection Tool” to move the characters in the paragraph as 
you would move any other graphic object

2. Use the “Text Tool” to insert blank lines between paragraphs

3. Use the “Text Tool” and the “Paragraph Spacing” dialogue box 
available from the Text->Paragraph Spacing...

Using the third method allows you to dictate the exact size of gap in points 
(1/

72
 inch).

There is no gap between these two 
paragraphs.

Choose Text->Paragraph Spacing... 
from the main menu bar.

Here the value has been changed to 
6 points.

The paragraphs are now 6 points 
apart.

Select multiple paragraphs to alter 
the spacing of them all at once.

1

2

3
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Letter Spacing
The space between individual letters can be controlled to an accuracy of 
1/

1000
 em. This is useful for achieving layout effects such as fitting text into a 

particular area by reducing or expanding the spacing.

Letter Space & Word Space

Due to the nature of PDF documents, you can also control the gap between 
words caused by space characters though this is generally not as widely 
used as letter spacing.

1 em

Letter spacing is measured in ‘ems’ 
with 1 em being the width of a capital 
letter ‘M’ in any font.

Letter space Word space

The letter spacing dialogue box uses 
units of 1/

1000
th em.

You can control the gaps between 
letters and words by entering positive 
or negative values.

The word spacing value is ignored 
when text is fully justified.

Notes
• Word spacing has no effect when text is fully justified.
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Select the “Text Tool” and begin 
editing a block of text.

Select the characters whose spacing 
is to be changed.

In this example the spacing is being 
changed to 100/

1000
th em. This will 

change the gap to be 1/
10

th of the 
width of the letter ‘M’ in this font.

The additional spacing is clearly 
visible and the text now covers a 
wider area.

Starting with the original text, the 
word spacing could be changed 
instead.

The word spacing is changed to 
400/

1000
th em or 0.4 x width of ‘M’.

The new, enlarged gap between the 
words is clearly visible.

1

2

3

1

2

3

Using Letter Spacing

Using Word Spacing
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Tabstops
Use tabstops to create sophisticated text layouts. Choose from left, centre 
and right justified tabs with or without leader dots.

Creating/Deleting Tabs

Click on the ruler bar at the position you want to create a new tab.  

Click & drag an existing tab-stop to move it to a new position.

Click & drag an existing tab right off the ruler bar to delete it.

  tab centre tab right tab

Notes

• Tabstops are remembered even after closing and re-opening a document.

• As you add or move an existing tabs their numeric position is shown in the 
status bar at the bottom of the window.

• Tabstops may be positioned beyond the left & right margins of the text box.

Screen Display When Using Tabstops

Tab characters are shown 
as small pink arrows 
during editing
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Creating Centre & Right Tabs

Position the mouse cursor over an 
existing left tab then press the right 
mouse button to see the Tab menu.

Choose Center or Right to change the 
type.

Tab Leaders

From the Tab Options... dialogue box, you can set the leader character or 
modify the way tabs wrap across lines.

Position the mouse cursor over the 
tabstop you want to modify.

Press the right mouse button to 
display the tab menu and choose Tab 
Options...

To add leader dots to your tabstop, 
type a single ‘.’ (period) into the 
Leader Character text box.

You can type any single character into 
this box for use as a tab leader.

Leaders are highlighted in green since 
Infix treats them as “text fields”.

Notes
• You can disable text field highlighting from the File->Preferences... dialogue 

box.

• Text field highlighting does not effect printing.

2

1

3
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Trailing Tab Leaders

Use the Tab Options... dialogue to control the way tab leaders are drawn for 
wrapped lines.

Position the mouse cursor over the 
tabstop you want to modify.

Press the right mouse button to 
display the tab menu and choose Tab 
Options...

When Trailing Leaders is checked, Infix 
will add leader dots to the end of a 
line that wraps because of a tab stop.

Trailing leaders have 
been added by Infix.

Notes

• Trailing leaders cannot be selected or edited with the text or object select 
tools. The caret will skip over them when moving through text.

• Trailing tab leaders extend up to the right edge of the text box.

1

2
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Vertical Text Alignment
Infix Pro can align text inside a text box so that it sits at the top, middle or 
bottom of a text box. It can also make text automatically fit its text box by 
altering various aspects of the text formatting (see Text Box Fitting)

Edit a text box using the text 
tool then choose Text->Box 
Alignment->Top.

The text shown here is Top Aligned 
which is the default alignment.

Text->Box Alignment->Middle.

Text->Box Alignment->Bottom.

Notes
• Text Box Alignment reverts to “Top” for linked text boxes.
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Text Box Fitting
Infix can alter various aspects of text formatting in order to make text fit 
inside its text box.

Edit a text box using the text 
tool then choose Text->Box 
Alignment->Full...

The text shown here is Top Aligned 
which is the default alignment.

Use the Text Box Fitting Limits 
dialogue box to select the aspects of 
formatting which should be modified 
and by how much.

During fitting, Infix tries altering the 
enabled aspects of formatting in the 
order they are listed in the dialogue.

The fitting process stops as soon as an 
acceptable result has been achieved 
even if all metrics have not yet been 
used.

Deactivate fitting metrics by un-
checking their check boxes.

The first two metrics simply adjust the 
word and letter spacing of text to try 
to achieve a fit.

The adjustment is between the 
supplied limits and is in addition to 
any spacing metrics already in effect 
on the text.

Continued...
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The Leading Scale metric modifies the  
leading and paragraph spacing of text 
within the percentage limits supplied.

In this example, leading and 
paragraph spacing could be increased 
from their initial values by as much 
as 200% during fitting (or reduced to 
75%)

Fitting may be restricted to text that 
overflows its text box (overset text).

Continued from previous page

Adjust the gap between paragraphs 
independently of the leading via this 
metric.

Adjustments range between the Min 
and Max point values supplied. If Min 
is set to 0 then paragraph spacing 
will never be reduced. If Max is set to 
0, paragraph spacing will never be 
increased.

The final metric adjusts the font size 
of all text in a text box by the same 
number of points in order to obtain 
best fitting.

Continued...
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Notes
• Text fitting is computationally expensive. It is not advisable to edit text with 

full fitting activated. Apply it only once editing is complete.

• Text Box alignment is remembered even after closing and re-opening 
documents.

• Original formatting (font size, leading & spacing) is restored once full fitting 
is turned off.

• Unlike the other alignment modes, full text fitting can be applied across 
linked text boxes.

Default “Top” alignment for two linked text boxes

“Full Alignment” applied across both linked text boxes.
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Choose the “Rotate Tool” 
from the toolbar and rotate 
everything by 90º.

To ensure the rotation hits 90º hold 
down Shift while rotating- this will 
“snap” rotation to 45º increments.

To edit the title “Bushnell 
Auto Group” first choose the 
“Selection Tool” from the 
toolbar.

Then choose Edit->Select All or press 
Ctrl-A to select everything on the 
page.

Editing Rotated Text
The techniques illustrated below show how to modify text written at an 
angle.

You may not need to follow all the steps shown in the examples below.

In this example once rotated, the 
page is too big for the page size. In 
this case the “Select Tool” is used 
again to scale the page so that it fits 
within the white page area.

Shift is held down while scaling to 
ensure the aspect ratio is retained.

1

2

3 Continued...
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Choose the “Text Tool” from the 
toolbar and edit the text as normal.

In this case the word “Auto” is being 
replaced with the longer word 
“Vehicle”.

During editing the text wraps onto 
the next line.

Once editing is finished select 
everything on the page using 
the “Selection Tool” and the 
Edit->Select All menu option.

Then, switching to the rotation 
tool, rotate everything back in 
the opposite direction by 90º

After rotation the document can be 
scaled to restore its original size.

To restore the text to a single line, 
stretch the right hand side of the text 
box.

4

5

6

7

Continued from previous page
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Drop Caps
Due to the way text flows around a drop-cap letter, you will need to follow 
the steps shown below to avoid losing the shape of the paragraph when 
editing.

Select the “Selection Tool” 
from the tool bar and drag the 
drop-cap letter(s) out of the 
paragraph.

1

Select the “Text Tool” from the 
tool bar and click inside the 
paragraph to begin editing.

2

To preserve the space left for the 
drop-cap, select the lines of text that 
form the “hole”.

In the image shown, these lines and 
some others have been selected.

3

Continued...
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Choose Text->Fix Line Widths from the 
main menu to lock the shapes of the 
selected lines.

4
Ruler goes light-blue when 
caret is in a line with fixed width

Fixed width lines have an 
additional border around 
them showing the shape of 
the line.

5

Edit the paragraph as normal. Infix 
will not alter the shape of the fixed 
lines even after reflow.

Make sure the alignment is correct. 
Infix may have chosen the wrong 
alignment due to space left for the 
drop cap.

6

Note
• If you need to, you can alter the shape of fixed lines - see Flowing Text Around 

Graphics

• You cannot use Text->Fix Line Widths on rotated text.

Finish editing by selecting the 
“Selection Tool” from the tool 
bar. 

Drag the drop-cap letter(s) back into 
the space left in the paragraph.

7

Continued from previous page



82 Advanced Text Editing

Flowing Text Around Graphics (Run-around)
In order to retain the contour of a paragraph that flows around a graphic the 
widths of lines should be locked during editing. 

Select the “Text Tool” from the 
tool bar and click inside the 
paragraph to begin editing.

Select lines whose shape follows the 
contour of the graphic. Lines that do 
not follow the shape need not be 
selected.

In this example every line of the 
paragraph needs to be selected.

Choose Text->Fix Line Widths from the 
menu bar to lock the selected lines.

“Fixed” lines have an addition border showing 
the shape of the line.

1

2

3

Continued...
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Edit the text as normal.

Although the text will reflow, the 
shapes of the fixed lines will not alter.

You can alter the shape of each line 
by moving the left or right margin.

Note
• If you want to alter the shape of lines to better follow the contour of a 

graphic, see Reshaping Text Run-around.

• You cannot use Text->Fix Line Widths on rotated text.

Finish editing as normal.

In this example, each line has been 
reshaped to ensure the new text 
curves around the blue oval.

5

6

Make sure the alignment is correct. 
Infix may have chosen the wrong 
alignment due to unusual shape of 
the paragraph.

Continued from previous page

4
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Use the “Text Tool” to select the 
entire paragraph. 

Choose Text->Fix Line Widths from the 
main menu bar to lock the shape of 
the paragraph.

Make sure the paragraph alignment 
is correct. Infix may have chosen the 
wrong alignment due to shape of the 
paragraph.

Reshaping Text Run-around
When editing a paragraph with an unusual shape or that flows around a 
graphic, Infix will change its shape so that it becomes aligned left, centre or 
right or fully justified.

To avoid losing the shape of an existing paragraph, you can “lock” the 
shapes of the important lines.

The gap between the text and image 
shown left is too large.

A few of the lines of text need shifting 
to the left to close the gap.

1

2

3

Continued...
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Slide the ruler’s left margin to move 
the left edges of the selected lines.

The same can be done for the right 
edges if needed.

5

After adjustment and reflow, the lines 
appear closer to the image contour.

The paragraph still appears a little 
ragged due to there being only one 
word on the last line.

See the following page for tips on 
improving this.

6

Notes
• Adjusting the left or right ruler margin of a “fixed” line controls the left and 

right edges of the line directly and has no effect on the left/right indents 
applied to the whole paragraph.

• You cannot use Text->Fix Line Widths on rotated text.

4

When “fixed”, an additional border is 
shown around lines illustrating their 
shape.

Select the lines needing adjustment. 
In this case three lines have been 
selected.

Continued from previous page
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Making Paragraphs Fit The Space Provided
With careful use of the line and letter spacing controls, edited text can be 
made to better fit the space it originally occupied.

After editing, this text has been left 
looking unbalanced because the last 
line has just a single word.

Select the entire paragraph (double-
click the left mouse button twice).

Choose Text->Letter Spacing... from the 
main menu bar.

Enter a new value for letter spacing. 

In this example, the paragraph is 
fully justified so word spacing has no 
effect. Otherwise this value could also 
be used to adjust the layout.

1

2

3

Continued...

Continued...
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The text has been expanded slightly 
to better fill the available space. The 
expansion used is small so the reader 
should be unaware of the effect.

The paragraph now looks more 
balanced.

Notes
• Using a combination of small adjustments to line spacing and letter spacing 

most text can be made to better fill the available space.

• In extreme cases, small adjustments to font size or line-spacing may also be 
required.

• Infix Pro can do paragraph fitting automatically. See Text Box Fitting for more 
details.

4

Continued from previous page
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Basic Find & Replace
Using the Find & Replace facility you can search for and replace words  
and phrases throughout a document, text boxes or range of pages.

Check this box if 
capitalisation is 

important

Press here to see 
previous searches 

If left unchecked, a search 
for “in” would also match 
“running” and “ingrowing”

Type the word(s) 
you are searching 

for here.

Press to display 
the “Replace” 
dialogue box

Click here to 
limit searching 

to specific 
pages

Click to control the way 
replacement text is reflowed, 

its font, size & colour

Click here to limit the 
search to certain fonts, 

sizes and colours of text.

Opens an interactive 
listing of all found or 

text

Check to activate wild card matching. 
Available wild cards are:  
 * to match zero or more characters  
 + to match 1 or more characters 
 ?  to match a single character

Continued...
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Notes
• If you have a word selected when the “Find” dialogue box opens, the word 

will be copied into the Find: box automatically.

• Be careful when changing text in paragraphs with unusual shapes (such 
as those that flow around graphics). When paragraphs are reflowed, their 
layout may be altered. See Advanced Editing for methods of avoiding with this.

• If the Replace: text cannot be rendered in the font of the text being replaced, 
you may see a dialogue box like the following: 

 In this case, try setting the font used for the replacement text by pressing 
the Format... button next to the Replace: text. See the following pages for 
further information.

Continued from previous page
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Find & Replace With Styled Text
You can search for a word or phrase formatted with a particular font, size or 
colour. You can also search for all text formatted in a particular way.

Minion-Italic, 7 point 

1

2

Choose Edit->Replace... to open the 
Replace dialogue box.

The selected text will appear in the 
Find: box.

To change all the character names 
in a Shakespeare script so that they 
appear in blue...

Using the text edit tool, select 
an example of the text to be 
changed. 

To find all text with the same style, 
un-check the Find: check box. The 
target text will grey-out.

Continued...

Next, click on the Character Format 
hyperlink to open the formatting 
dialogue box.

3
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Whenever a format is active for a 
search, a brief summary of the styles 
chosen is shown next to the Find: text 
box.

3

Continued from previous page

4

The Find Format dialogue reflects the 
formatting of the text from your initial 
selection, though it remains inactive 
until you press OK.

Press OK to activate the formatting.

Click on the hyperlink next to the 
Replace: text box to open the Replace 
Format dialogue box.

5

The Replace Format dialogue box 
displays the formatting of the initial 
text selection.

Click on the Fill colour checkbox to 
enable the colour picker button next 
to it. 

Click on the colour button to choose a 
new colour.

(In the example image a blue colour 
has already been chosen)

6

Continued...
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7

Continued from previous page

Reflow and alignment changes 
should be kept to a minimum (we 
only want to change text colour).

Ensure that Reflow: is New Text Only 
and Alignment: is Left.

Then press OK to activate the 
formatting.

8

Un-check the box next to Replace:. 
The replace text box will grey-out.

Press the OK button to activate the 
format settings.

The Replace dialogue box 
should look something 
like this.

Press Replace All to start 
the process which may 
take some time to finish.9

Continued...
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Continued from previous page

Once finished, all character names 
have been changed to blue 
throughout the document.

10

Notes

• To remove any Find: formatting click the formatting hyperlink next to the 
Find: text box and set Font & Font Size to “Any” then un-check both colour 
check boxes.

• Replace: formatting can be disabled in the same way as detailed above.

• Infix will save a partial copy of the document every 100 or so pages during a 
long Find & Replace operation.

• To cancel a Find/Replace operation, press Escape or close the dialogue box.
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Text Reflow Modes
Infix offers three modes for controlling 
the way text is reflowed during search and 
replace:

1. Reflow: New Text Only

This mode is useful when dealing with tabular data, headers, footers or 
other single lines where retaining the original spacing and gaps between 
words is important. 

The minimum reflow is done. The new text is left, centre or right aligned 
within the space occupied by the text being replaced.

In this mode, you may end up with words printed on top of each other if the 
replacement text is much longer than the original.

2. Reflow: Containing Line Only (default mode)

This mode is useful when you wish to cause minimum changes to existing 
paragraphs whilst ensuring changed lines blend in correctly. 

Only the line (or lines) containing the search text will be reflowed after 
replacement. Lines can left, centre or right aligned regardless of the 
alignment of their paragraphs. 

The ‘auto’ option will use the containing paragraph’s current alignment.

3. Reflow: Containing Paragraph

The entire paragraph (and those near it) may be reflowed according to their 
current alignment. You cannot dictate the alignment used in this mode.

If paragraph grows longer after reflowing, some of their text may become 
‘overset’. This is signified by a cross displayed in the text box around 
the containing text block. You may need to make the text box bigger to 
accommodate the text.

Continued...
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Reflow: New Text Only

1

In this example, the header text is to 
be altered whilst retaining the gap 
between the page number and the 
text.

Choose the Edit->Replace... menu item. 

Fill in the Find: and Replace: text boxes.  
Press the hyperlink next to the Replace: text box. 

To ensure that the new text is right-
aligned and that the page number is 
left where it is -

Choose New Text Only from the Reflow: 
pop-up menu

Choose Right from the Alignment: 
pop-up menu

Continued...

2

3

Continued from previous page
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Editing Graphics                 13

        Editing Graphics 13

        Editing Graphics         13

Align: Left 
New text is aligned with the start of the 
old text. If new text is longer than old, 
it may overflow and collide with page 
number.

Align: Centre 
New text is aligned with the centre of 
the old text. If it becomes longer it will 
extend beyond the original left/right 
bounds of the old text.

Align: Right 
New text is aligned with the end of the 
old text. If new text is longer than old, it 
may extend beyond the left extent of the 
original text.

Editing Graphics 13
Reflow: Containing Paragraph 
The entire line is reflowed and left 
justified. The page number is moved 
during the reflow.

Reflow: New Text Only

Editing Graphics & Images 13Original text

Continued from previous page

Continued...
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To make room, the words have been 
moved closer together on the first 
line. 

None of the other lines has been 
altered.

2

“Cigar Club” -> “Old Smoking Society”

There is not enough room for the 
replacement text on the line so words 
have begun to run-in to each other.

This is the same replacement using 
Alignment: Left. 

The text has grown beyond the edge 
of the text box.

Potential Problems

Reflow: Containing Line Only

“Cigar Club” -> “Smoking Society” 

In this example, “Cigar Club” is 
replaced by “Smoking Society”, 
reflowing only one line of the 
paragraph.

1

Continued from previous page

Continued...
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Find & Replace In Long Documents
During find & replace in a long document (more than 100 pages), Infix will 
save the partially complete document every 100 pages.

On completion, the finished document MyDoc.pdf will be renamed MyDoc-
BigEdit.pdf. The original document (before the find & replace) will remain 
unchanged.

Notes
• Use Reflow: Containing Paragraph option only if you are confident that 

reflowing the paragraph will not destroy any existing indentation or special 
layout.

• When using Reflow:New Text Only the new text may collide with existing text 
if it longer that the original text.

Continued from previous page
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Find & Replace In Files
Infix Pro can automatically perform a Find & Replace operation on multiple 
files. This can be useful when the same changes need to be made to many 
files.

Choose Edit->Find & Replace In Files... to open the dialogue.

You do not have to have a document open already to use it.

Upper part of the dialogue 
is like the Find & Replace 
dialogue box.

Lower part of the dialogue 
is where you add files to be  
searched.

Click to add files to the list

Continued...

Deletes files from the 
list (does not delete the 
actual file from disc)

1

2

Click to add all 
the PDF files in 
a folder (and its 
sub-folders)
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Continued from previous page

Once your search has been setup and 
you have added some files to the list, 
press Replace All...

The Setup Folders dialogue will open.

Supply a location in which to save the 
processed files. 

If you do not use this option, your 
original files will be over written (a 
backup will not be made). 

You are strongly advised to ensure 
you have a backup of the original files.

You may also give an optional folder 
for error files. 

Errors can occur when there is no 
suitable font for substitution for 
example.

3

4

5

Continued...

Setup Folders
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During the search, the dialogue 
shows the number of changes made, 
and current page being searched.

When doing Find In Files, pressing 
Show Results will display the results 
list. This list is updated as the search 
proceeds. 

Once the search has finished, double 
clicking on a result will open the 
relevant document and show the text.

Continued from previous page

6

The current document being 
searched is highlighted in the list of 
files.
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Rotating Pages
Pages can be rotated in 90˚ steps. 

Choose Document->Rotate Pages... 
from the main menu.

Choose the rotation angle and range 
of pages to be rotated.

The dialogue box also displays the 
current rotation of the page being 
viewed.

1

2
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Press the Crop Tool on the main 
toolbar.

Drag-out a box to the size you wish 
to crop. Everything outside of the box 
will be cropped.

After dragging out the crop box, you 
can continue to adjust its shape using 
the resize handles. 

Cropping Pages
Pages can be cropped to hide unwanted parts. 

Press Return to open the Crop 
dialogue box.

Now choose the pages to which the 
crop should be applied.

To change an existing crop, remove it 
first using Document->Remove Crop... 
then add a new one.

Notes
• Press Escape after drawing the crop box to abort the crop operation.

• Double-click the left button without drawing a crop to open the Remove 
Crop dialogue box.

• Objects that fall outside of the crop box are hidden from view but still 
remain a part of the page.

1

2
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Removing Page Crops
If part of a page is hidden by a page crop, you can remove it to reveal the 
areas.

There are two ways to remove an existing crop from a page or range of 
pages:

1) Press the Crop Tool on the main toolbar.

 Double-click the left mouse button.

2) Choose Document->Remove Crop... menu item.
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Inserting New Pages
You can insert any number of new pages into any PDF document.

Open a document then choose Document->Insert New Page...  from the main 
menu bar.

1 432 5

Choose how many new pages you 
want to add (the default is 1).

Choose whether you want to 
insert the new page before or 

after an existing page.

Inserting a new page 
After the First Page

Inserting a new page 
before Last Page

Notes
• The size of new pages is determined by the page being viewed when the 

instruction is given.

Choose User Current Size to make 
the new pages the same size as 

the currently displayed page.

The remaining options are 
the same as those in the New 

Document dialogue box.
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Moving Pages
A page or group of pages may be moved from one part of a document to 
another. You may have to alter page numbers printed on the pages after 
relocating.

1

213 4 5

5431 2

2

Open a document and choose 
Document->Re-order Pages...

Choose the range of pages you wish 
to relocate.

Then choose where you want them to 
be moved to.

Relocating pages 1 
and 2 to page 4.
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Resizing Pages
A page or group of pages can be resized. This scales all objects on the page 
then adjusts the media box (paper-size). 

11.00 in

8.27 in

Open a document and choose 
Document->Resize Pages...

Choose to scale X & Y axis 
independently or click Constrain 
Proportions to maintain the aspect 
ratio.

Choose the units for scaling - percent,  
inches, points or centimetres

This illustrations shows a page being 
resized by 50% on both axes.

4.13 in

5.50 in

Un-check this box to re-size the page only; objects 
on the page will not be altered. This is especially 
useful for re-sizing empty pages.
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Inserting Pages From Other Documents
A range of pages can be imported from other documents into the current 
document.

With your document already open, 
choose Document->Insert Document... 

Choose the document you wish 
to insert using the file selection 
dialogue.

1a

1b

After dropping the file, choose Insert 
the PDF...

Alternatively, Drag & Drop and 
PDF document onto the main Infix 
window. 

1c

Continued...
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1 432 5

2

If the document you are importing 
has more than one page, you can 
choose the pages to be imported. 

Inserting a group of 
pages After the First Page

Inserting a group of 
pages Before the Last Page

Continued from previous page
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Placing Pages From Other Documents
You can place the contents of an entire page from another document into 
the current page of your document.

1

2

If the document you are placing has 
multiple pages, choose the page you 
wish to place.

This dialogue box will not be 
displayed if the document being 
placed has only one page.

You can “drag & drop” a PDF file onto 
your open document to place a page.

You will then have the choice of 
opening, placing or inserting the new 
document.

Use the Document->Place PDF menu 
or “drag & drop” the document onto 
your open PDF. 

1
2

3
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Exporting Pages As Other Formats
Infix can export pages or entire documents as plain text, HTML, RTF, TIFF 
and JPEG.

Conversion Formats

Open the document to be converted.

Choose File->Export As... 

Choose the conversion: plain text, 
HTML, RTF, Tiff or JPEG.

Choose the pages to be converted.

Plain text

HTML  
(Images as PNG)

RTF + Images

Multi-page Tiff

JPEG

HTML3 - <H1>, <H2> etc...

HTML 4 - <FONT SIZE= etc...

HTML 4  - separate style sheet file

HTML 4 CSS with layout

Notes
• The JPEG & Tiff conversions render entire pages and not individual images.

• To export images only, select one of the HTML conversions. All images will 
be exported as PNG files and placed in the same folder as the HTML output.
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Sticky Notes
You can create new or edit existing “sticky note” annotations in documents. 
These are small pop-up windows designed to contain short messages such 
as approval or editorial comments.

Anatomy Of A Sticky Note

Stick note icon. 

This can be moved around independently of the 
sticky note window.

Double-click the icon to toggle the main note 
window open or closed.

Close box

Resize box

Title bar - shows name of note 
author, title, date and time of last 

modification.

Message area 
with scroll bar

Notes
• If you can not see the sticky-note window after double-clicking on the sticky 

note icon, try scrolling the page or zooming out. It may be off the screen 
somewhere.

• There are a number of alternative icons available - see Stick Note Properties for 
details.

• To change the author’s name assigned to new notes, choose 
File->Preferences... from the main menu.

• Sticky notes are not included when printing documents.
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Click the Stick Note Tool in the main 
toolbar.

Drag-out a box to denote the size of 
the new sticky note. 

Alternatively, single-click the left 
mouse button to create a standard-
sized sticky note window.

Creating Sticky Notes

Deleting Sticky Notes

Sticky notes can be deleted in two ways:

Using the Hand Tool or 
Sticky Note Tool, click on 
the sticky note icon to 
select it.

Then press Backspace or Delete on the 
keyboard.

a selected sticky 
note icon

1

Using the Hand Tool or Sticky Note 
Tool, right-click on the sticky note 
icon and choose Delete.

2

If you have not already set up a user 
name using File->Preferences..., Infix 
will now ask you to supply one.

This user name will be recorded in 
each sticky note you make.

1

2
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Sticky Note Properties

Various properties of sticky notes can be modified such as the icon and 
colour can be changed using the Sticky Note Properties dialogue box.

1

Select the Hand Tool or 
Sticky Note Tool from 
the toolbar.

Click the right mouse button over 
the sticky note icon and choose 
Properties...

2

Use the dialogue box to change icon, 
colour, title and author.

The modification time cannot be 
altered manually.

Comment

? Help

Insert

NP

Key

New Paragraph

Note (default)

¶ Paragraph

Sticky Note Icons
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3

Choose the action to be performed 
when the reader clicks on the 
hyperlink:

• Go to view 
• Open a file 
• Word Wide Web Link

Changing the Action Type: option 
will cause the bottom section of the 
dialogue box to change.

Hyperlinks
Use hyperlink annotations to create interactive boxes which, when activated 
by the reader, will jump to another part of the same document, a different 
document or web address (using an external HTML browser).

2

Click on the Link Tool button in 
the main toolbar.

Drag-out a box to denote the shape 
of the hyperlink region.

1

After drawing the hyperlink box, 
the Link Properties dialogue box is 
displayed.

Continued...
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Action Type: Go To View

Return to the dialogue and choose 
the Magnification: for the destination 
view.

Press OK to create the hyperlink.

Continued...

4a

Choose Go To View

Whilst the dialogue is still open, 
return to the main document window 
and navigate to the page and position 
you want displayed when someone 
clicks on the new hyperlink.

4b

Action Type: Open File

Press Select File... to choose the file 
to be opened when the hyperlink is 
activated.

Choose Open File

Continued from previous page
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Press Edit URL... to specify the address 
to open when the hyperlink is 
activated.

Web addresses should begin with 
“http://”

4c

Action Type: Go To URL

Choose World Wide Web Link

Continued from previous page
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About Bookmarks
Bookmarks allow readers to quickly navigate to specific places in a 
document and are especially helpful in long documents. Using Infix you can 
automatically add bookmarks to a document and edit existing bookmarks.

On Screen Display

To see a document’s bookmarks choose View->Bookmarks or press the F9 
function key.

Click on a bookmark item to 
see the part of the document 

to which it refers

Click on the plus/minus symbol to 
open/close sub-bookmarks

Sub-bookmarks of the “School 
Update” item

Divider bar can be 
moved left or right

Notes
• Drag a bookmark on the title of another to nest the bookmark within the 

other.

• Drag a bookmark on the icon of another to move without nesting within the 
other.
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Notes
• The quality and number of bookmarks created depends on the style of 

document used. 

• You may need to add, remove or move some bookmarks after auto creation.

• If you do not wish to include certain pages in the bookmark tree - title and 
contents pages for example, turn to a page after these before choosing  
Edit->Create Bookmarks.

Automatic Bookmarks
Infix can create bookmarks automatically. This is especially useful for long 
documents that have no bookmarks. 

The bookmarks for this guide were created this way and then edited to 
remove any unwanted entries that were added automatically.

With a document already open, 
choose Edit->Create Bookmarks or 
press Ctrl-B.

All pages from the current page 
onwards will be trawled in an attempt 
to find suitable bookmarks. 

If the document already has 
bookmarks, Infix will prompt you 
to proceed. If you do, all existing 
bookmarks will be removed before 
the new ones are added.

1

2
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Editing Bookmarks
You can manually create, delete, rename and move bookmarks.

Renaming Bookmarks

Click on an existing bookmark to 
select it.

After a short delay, click again to start 
renaming. The name of the bookmark 
will become selected, ready for 
editing.

Deleting Bookmarks

Click to select the bookmark item to 
be deleted.

Press the Delete or Backspace key to 
delete.

Note
• If you delete a bookmark item that has sub-items (as shown above), the sub-

items will also be deleted.

1

2
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Creating Bookmarks

A bookmark records the page number, location and zoom setting used to 
view the page at the time the bookmark was created.

Navigate through your document to 
the page you want to bookmark. 

Zoom and scroll the page to the exact 
position you want to record.

Click the right mouse button inside 
the bookmarks window. Select the 
Insert Bookmark menu option that 
appears.

The new bookmark will be created 
and named “New Bookmark”.

3

1

2

1

2

Click once to select the new 
bookmark.

After a short delay, click again to start 
renaming. The name of the bookmark 
will become selected, ready for 
editing.
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Moving Bookmarks

You can move bookmarks to different parts of the bookmark tree.

Click to select the bookmark to be 
moved.

Drag the bookmark and drop it onto 
the icon of the bookmark you want it 
to appear after.

The bookmark will appear after the 
bookmark you dropped it onto and at 
the same nesting level.

Moving To The Top
Move the bookmark you intend to be 
top so that it is second in the list (as 
shown above). 

Then select the first item in the list.

Drag the first item and drop it onto 
the icon of the second item (the one 
you want to be top).

The two bookmarks will switch 
places.

1

2

3

1

2

3
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Changing Bookmark Nesting
You can nest bookmarks within other bookmarks or move them out to a 
lower nesting level.

Nesting Bookmarks

Click on the bookmark you wish to 
nest.

Drag the bookmark onto the title 
of the bookmark in which it will be 
nested.

The bookmark is nested within the 
one on which it was dropped.

De-nesting Bookmarks
Click on a nested bookmark you wish 
to move to a lower nesting level.

Drag the bookmark and drop it on 
the icon of any bookmark with the 
nesting level you want.

The bookmark’s nesting will be 
changed so it matches the one on 
which it was dropped.

1

2

3

1

2

3



Document Font Catalogue
Document Properties
Flight Check
Security Settings
Tracking Changes

☞

☞

☞

☞

☞

Document Operations

127



128 Document Operations

Full path name of the document and its 
size on disc.

Document Properties
A summary of the settings, dates, author and other information about the 
current document can be viewed by choosing Document->Properties...

Document meta data.

This data is stored in a non-human 
readable form inside the PDF and also 
as plain text within an XML tag named 
<Properties> nested in another named 
<IceniSetup>.

Click on the Modified: date to open the 
document’s Change Log.

Click on the Security: hyperlink to open 
the Document Security dialogue box.

Click on the User Restrictions: hyperlink to view/
modify the settings controlling how users may 
edit this document. 

Resource Page: indicates if the document has an 
embedded Iceni resource page. This can be useful 
for distributing PDF templates.

 Document Properties 128
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Security Settings
Using PDF security settings you can limit what other people can do with 
your document. For example, you can stop other people editing or printing 
your document. 

View Current Settings

To check the security settings for a document, choose Document->Security... 
from the main menu.

The security dialogue box will initially display with most controls inactive.

If enabled, click Unlock... 
to change security 
settings.

The inactive controls 
show the current 
security settings for the 
document.

If the document has an existing 
Master Password, you will have to 
enter it now.

If you do not know the Master 
Password, you will not be able to alter 
any of the security settings.

1

2
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Security Settings Dialogue

Using Infix you can add or modify security settings on documents. 

Infix support 48-bit (Acrobat 3 and above) and 128-bit (Acrobat 5 and 
above) password encryption.

Security level:

• None 
• Acrobat 3+ (48 bit) 
• Acrobat 5+ (128-bit)

128-bit security is harder to defeat and 
offers finer control over what operations 
are allowed on your document.

Older style 48-bit security is more 
compatible.

User Password: 
If set, a password must be entered before 
the document can be viewed or printed.

Master Password: 
If set, a password must be supplied 
before changes can be made to security 
settings.

The things other people are allowed to 
do with this document.

For example, if you want people to be 
able to add sticky notes without being 
able to change the content of the 
document, choose Comments & Form-
filling

Notes
• If you forget a document’s User Password, you will not be able to open the 

document.

• If you forget a document’s Master Password, you will not be able to alter the 
security settings in future.

If un-checked, users will have to supply 
the Master password to be able to unlock 
locked objects.

This can be useful when distributing 
templates.
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Tracking Changes
Infix can highlight text that has been modified during previous editing 
sessions. It also records the date, author and page number of all changes 
made to documents (see step 3 below).

1

2

3

Choose File->Preferences...

Ensure Show changed text in: is 
enabled.

You can also choose the colour used 
for highlighting.

Text that has been modified in this or 
previous sessions will be highlighted 
using the colour chosen in the 
preferences dialogue box.

To see a complete history of all pages 
modified using Infix (version 2 or 
later) choose Document->Change Log.

Continued...



132 Document Operations

Notes
• Infix cannot highlight text that has been deleted. It will however, record that 

a modification has been made to the page that used to contain the text.

• Only changes made with Infix version 2 (or later) are recorded.

Continued from previous page

User Elangkumaran C modified the document on 
Friday, 4th August, 2006. No particular page was 
edited (Perhaps security settings were modified.)

User Guy Bushnell modified pages 1, 2, 16 to 48 and 
some others on Wednesday 5th September 2007.
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Document Font Catalogue
Infix can list all of the fonts used in a document plus additional information 
about the nature of each font.

Choose Document->Fonts... to view the font catalogue.

Names of fonts currently embedded in 
the document.

Fonts introduced during the current 
editing session will not appear until the 
document is saved.

Names prefixed with “XXXXXX+” 
represents subset fonts.

Font types can include any that are 
supported by the PDF standard - 

TrueType, Type1, Type3, OpenType etc..

During editing, Infix can only embed 
TrueType fonts taken from your 

computer’s system.

Shows the font being used for on-screen 
display. 

If the font is embedded in the PDF it will be 
used and labelled “embedded”. 

If the font is not embedded in the PDF the 
font substitute chosen by Infix will be shown. 
This may be from Infix’s built-in fonts or from 
your computer’s system fonts.

“Yes” indicates that 
the font has a built-in 
mapping to Unicode 

The number of character 
shapes defined by the font.

Notes

• When editing text, choose Text->Character Palette... to view all of the glyphs 
contained in a font.
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Flight Check
Infix includes a basic flight-checking function. A check for overset text is 
always made prior to saving a document. 

Two additional checks are available for users of Infix Pro or for those editing 
a document with user restrictions; these are 

 • a check for images of less than 300dpi resolution 
 • a check for non CMYK colour spaces 

Choose File->Flightcheck... (Infix Pro only) to open the Flight Check dialogue 
box.

Un-check to avoid certain tests

Shows the numbers of problems 
found for each kind of test (even if 
the test is disabled)

Describes each problem found 
giving the kind of object effected 
and the page.

When saving a document, the flight 
check dialogue always checks for 
Overset Text (& possibly more).

Press Save Anyway... to ignore any 
problems and save the document.
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Open your document.

This example uses a basic envelope 
design produced using Infix or any 
other design application capable of 
generating a PDF.

Using the text tool, drag out a 
central text box for the address. 
Ensure it is big enough to 
accommodate most addresses.

Enter some sample text to indicate 
where the user should type.

Choose a font and size for the sample 
text so that users of the template do 
not need to bother. 

Basic Templates
Infix can create and use templates (sometimes 
known as stationary) for things like 
memos, envelopes and faxes that you use 
frequently.

The initial layout is created using your 
preferred design application then converted  
into a PDF template using Infix.

When a user opens a template, the document 
name becomes Untitled so that the original 
template is never over written. 

Email: 
sales@iceni.com

Web:
www.iceni.com

Fax: 
+44 (0) 1603 617 415

Telephone: +44 (0) 1603 628 289

Address: Sackville Place, 44-48 Magdalen Street, Norwich, England, NR3 1JU

TO ADDRESS

Date:

RE:

Sender: Iceni Technology Ltd., Sackville Place, 44-48 Magdalen Street, Norwich NR3 1JU ENGLAND

"Liberating PDF content"

RECIPIENT'S ADDRESS HERE

1

2

[FIRSTNAME]

[JOBTITLE]

[FAMILYNAME]

email: [EMAIL]

mobile:[MOBILE]

landline: 01603 628289 / x25IDZat

Continued...
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Continued from previous page

Choose File->Save As Template... to 
display the User Restrictions dialogue 
box.

 
Template PDFs are saved with the 
extension .pdt instead of .pdf.

The User Restrictions dialogue can be 
ignored for simple templates.

For more advanced templates, use 
this dialogue to limit how users 
interact with the template. For 
example, limiting the fonts they can 
use when editing.

Press OK to save the template.

User Restrictions
Once applied, User Restrictions are effective in all versions of Infix but can 
only be removed or altered using Infix Pro.

To view and change the restriction choose Document->User Restrictions... or 
click on the Restrictions hyperlink in the Document->Properties... dialogue 
box.

• Approval required after editing 
Documents based upon templates will have an ‘Approval Required’ 
watermark added when saved. This can only be removed using Infix Pro.

• Basic flight check on save 
Infix checks for a minimum of 300dpi resolution on all images in the 
document and for CMYK colour spaces. This is in addition to the standard 

Continued...

3

4
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check for overset text. 

•  Edit using existing fonts only / Edit using existing colours only 
Limits the available fonts and/or colours that can be used to those 
already in use in the document. This helps to ensure users do not deviate 
from the initial design goals or corporate identity colour schemes.

When colours are restricted, users are presented with the Swatches 
dialogue when they wish to change the colour of an object.

• Disable text scaling 
When scaling objects, text boxes are not be affected.

• Lock left alignment of all objects 
Limits the directions in which objects may be moved. 
Text boxes may be resized to allow for more text for example, but their 
position along their x-axis cannot be altered. This is to help maintain the 
essence of the design’s original layout.

• Preserve aspect ratio during scaling 
Ensures that no objects can be stretched out of proportion. Any scaling is 
applied equally to both x & y axes.

Continued from previous page
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Highlighting Locked Objects

If your version of Infix includes the Show/Hide toolbar button, 
pressing it will toggle between two viewing modes. 

When on, all locked items are faded to make unlocked objects easier to 
identify.

Alternatively, all versions of the software include the  View->Locked Objects 
menu item to toggle between the two modes (or press Ctrl-Alt-L).

Unlocking Objects

Unlock all locked objects by choosing Object->Unlock All.

Locking Objects In Templates
Objects can be locked to ensure users of the template can only edit specific 
parts. This can help to ensure original designs are not accidentally altered by 
users.

Using the Object Select tool, 
select object(s) to be locked.

Choose Object->Lock Selection or 
right-click the mouse and choose Lock 
Selection

Objects will remain locked even after 
the document is saved and reopened.

To unlock a specific object, 
choose the Object Select tool 
and move the mouse cursor 
over the object.

Right-click the mouse and choose 
Unlock Object/s.

The object(s) under the mouse cursor 
will be unlocked and selected.
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Embedded Font & Colour Resources
To ensure portability and ease of editing, templates should include 
embedded font definitions for all the character shapes likely to be used.

For templates with a restricted colour palette (see “User Restrictions” earlier 
in this section) it may be necessary to define optional colours not yet used in 
the template but that may be used in future.

Both of these requirements can be met by including a “resource page” in 
your template.

abcdefghijklmnopqrstuvwxyz 
ABCDEFGHIJKLMNOPQRSTUVWXYZ 
0123456789 !"£$%^&*()[]
{};:'@#~`¬<>,./?-=_+\

Bistream Vera Sans

abcdefghijklmnopqrstuvwxyz 
ABCDEFGHIJKLMNOPQRSTUVWXYZ 
0123456789 !"£$%^&*()[]
{};:'@#~`¬<>,./?-=_+\

Bistream Vera Sans Bold

An example resource page containing 
two fonts and four colours.

The page can be prepared within Infix 
or using any other editor capable of 
generating PDF.

Choose: 
Document->Resource Page->Add... to 
embed the resource page within the 
currently open document.

The resource page will not appear 
as part of the document in any PDF 
viewer and will not be output if the 
PDF is printed.

Checking Resource Pages

The Document Properties dialogue box will show the existence of a resource 
page in a PDF.

Choose Document->Resource Page->Extract... to copy the embedded page to 
a new file and view it in Infix.
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Dynamic Text Using Tokens
For Infix Server to accurately find the target text you wish to replace in your 
templates, the text should form unique names or tokens.

[FIRSTNAME]

[JOBTITLE]

[FAMILYNAME]

email: [EMAIL]

mobile:[MOBILE]

landline: 01603 628289 / x25IDZat

For this business card, the artwork 
has been produced with tokens 
specifying the location of text to be 
replaced.

The font, alignment, margins etc. of 
the token will be retained when it is 
replaced by Infix Server.

Dear [CNAME],

Thank you for purchasing the [PRODUCT] on 
[PDATE].

We would like to take this opportunity to 
remind of our aware-winning after-sales 
care and invite you to sign-up for our free 
newsletter covering all aspects of the 
[PRODUCT]  plus hints and tips for getting 
the most out of it.

Here the tokens have been included 
within the body text. 

When replaced, the body text will be 
reflowed to ensure correct layout.

The [PRODUCT] token is using a 
different font to the rest of the body 
text.

Notes
• To ensure predictable reflow after token replacement in body text, prepare 

the PDF using Infix, setting text-box sizes and paragraph alignments etc.

• Reflow behaviour can be controlled by the name of the tokens themselves. 
This is useful for templates that have not been prepared using Infix. See the 
Infix Server user manual for more information.
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Dynamic Text Using Text Fields
The use of tokens such a [JOBTITLE] in a PDF template where layout or 
spacing is critical is sometimes impractical. In these cases, a block of existing 
text can be given a name without affecting the text itself. This name can 
then be used as a target for replacements via Infix Server.

In this example the box containing 
“A” is too small for a token such as 
[SECTION].

Using the Text Tool, select the 
“A”.

1

Right-click the mouse and choose 
Field Attributes...

2

Enter the token name into the Callout 
Name: text box. 

This is the name that will be used in 
the Infix Server configuration file.

3

Continued...
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Continued from previous page

You can (optionally) control how Infix 
Server will reflow the replaced text.

These two pop-ups behave the same 
way as those in the Replace Format 
Dialogue used during Find & Replace.

Infix can highlight all text fields on 
a page. See the File->Preferences... 
dialogue box to control this.

The colour used for each field is 
decided by Infix.

4

7

5

The Control: option instructs Infix 
Server to delete the field and its 
containing paragraph should it 
become empty after processing.

The content of the Description: field 
will be shown in a tooltip window 
whenever the mouse hovers over a 
text field. 

It will also appear after using the 
View->Go To Next Field menu item.

6
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Two scaling modes are available 
during automated image 
replacement:

• Crop to fit 
• Fit inside

The effect of each mode is illustrated 
below:

The Image Attributes dialogue box 
lists all of the attributes that can be 
applied to an image. 

Click on the Image name property and 
enter a new value in the Value: field at 
the bottom of the dialogue.

2

3

Dynamic Images
Images can be named so that they can be targeted for replacement 
using Infix Sever. You can also control the scaling used when the image is 
replaced.

Choose the Object Select tool.

Right click the over the image 
you want to name and choose Image 
Attributes...

Continued...

1
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Continued from previous page

Fit inside Crop to fit

Naming Multiple Images

Infix Pro offers a short-cut for naming multiple images. It also offers a way of 
checking whether images have been named already.

Choose the Object Select tool 
from the toolbar.

Then choose Object->Name Images... 
from the main menu bar.

1

2

Enter a base name for your images 
and set the scaling mode to be used 
for each.

The settings for individual images 
may be altered later by using the 
method detailed on the previous 
page.

Continued...
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An example of an image showing its 
label “image7”.

To finish naming images, press Escape 
or change to another tool.

Choosing the Object->Image Naming... 
menu option at any time in the future 
will show any existing image labels.

Continued from previous page

4

3

Click on each image to name it.

Every time you click an image it will 
be given a name by applying a new 
suffix to the base name you supplied. 
For example Image1, Image2, Image3.

The name will displayed within the 
bounding box of the image.
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Dynamic Line-Art & Graphics
By grouping objects together with a text field, the entire group can be made 
to appear or disappear depending upon the value of the text field.

This car ad template includes a 
triangular sign for carrying optional 
messages such “SOLD” or “SALE”.

If no substitute text is provided in the 
Infix Server configuration file, the sign 
can be automatically removed.

This approach may also be used 
together with Text Fields. 

To Create Optional Signs

1. Use the Object Tool to select the artwork and associated text then 
group them together using the Object->Group Selection menu option.

2. Ensure the text field has 
the “.d” suffix. This tells Infix 
Server to delete the containing 
paragraph if it becomes empty.

If Infix Server does delete the 
containing paragraph, it also deletes 
the other items in the group leaving 
just the text box and any other 
paragraphs it may include. 
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Dynamic Page Size
It can be useful if a template automatically grows to fit the text being 
flowed into it. Infix Server can do this by extending the length of a page and 
crop box as well as stretching and moving any relevant graphics and page 
furniture. 

Using the Text Tool, click inside 
the main text box of the ad.

The size of this text box after 
substituting text will be used to re-
size the entire ad.

Only one text box can be used to 
control overall ad-size.

1

Right-click the mouse and choose 
Text Box Attributes...

• Set Can Grow to True 
This means that  instead of text 
overflow resulting in an overset text 
box (and the text being invisible), 
the text box will grow downwards to 
accommodate all the text placed in it.

• Set Move Objects Below to True 
All objects below the bottom line of 
the text box will move as the text box 
grows this includes any text, borders 
and the actual page size itself.

2

Continued...
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Continued from previous page

Objects above key text 
box will not be moved 

or stretched.

Between top & bottom of 
key text box, objects will be 

stretched as the text box grows

Objects will be moved down as 
key text box grows

Unchanged

Key text box has been extended. 
Border around ad has been 

stretched in proportion to the 
text box’s growth

Objects moved downwards

Flowing new text into the key text 
box causes the ad to grow (along with 
the page & crop box)

Continued...
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Controlling Dynamic Page Growth

To ensure pages grow in predetermined steps (½ inch steps for example), 
set the Growth Step in the Text Box Attributes dialogue box to the required 
point size.

Here the Growth Step has been set to 
½ inch. This means the entire ad will 
extend downwards in jumps of ½ 
inch. 

This includes the page’s media box 
and crop box.

Notes
• The minimum size of the page is the size before any substitutions have been 

made. That is, the size when preparing the template in Infix Pro.

• Decorative, repeating borders and certain kinds of artwork may not respond 
well to being stretched vertically. Hence this approach may not be suitable 
for all ad types.
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PDF Compatability
Infix is compatible with all versions of PDF up to 1.6. 

Compressed object streams and transparency are supported from Infix 
version 3.03 onwards.

Annotations

Infix handles the following annotations:

• sticky notes 
• hyperlinks (go to view, go to file & go to URL) 
• Iceni “Table Box” & “Image Box”

Other kinds of annotation including interactive forms are not displayed 
though they are preserved in the PDF after editing with Infix.
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Editing Non-English Text
When editing documents written in various different languages please 
remember the following:

• hyphenation will only work if the correct language is chosen using 
the File->Preferences... menu option. If the correct language is not 
available, it may be better to disable hyphenation.

• spell check requires the correct language to be specified using the 
File->Preferences... menu.

• Infix only supports editing of text read left-to-right. This means 
editing of Arabic & Hebrew texts is not supported.

Double Byte Support

Infix fully supports copy/paste of double-byte characters.

A double-byte character can be typed directly by holding down Alt while 
entering the decimal value of the character using the numeric keypad 
(ensure that ‘NumLock’ is lit on your keyboard). The character will be 
inserted when you release the Alt key.

For example: Alt+0190 = ¾ 
(you do not need to type the ‘+’ character)

The character codes can be found by using the Character Map utility in most 
versions of Microsoft Windows. 

Display of Double-Byte Characters

When a document does not include a required font, Infix substitutes one 
of its built-in fonts. These fonts cover the standard Latin character sets plus 
Hiragana, Katakana and a selection of special characters. 

If you install the optional Asian Font Pack (available from www.iceni.com/
support) the built-in fonts can be extended to include a useful selection of 
Chinese and Japanese characters.

Characters for which no substitute exists will appear as squares in Infix but 
may display correctly in other viewers.
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Fonts In PDF
To be truly portable, a PDF must include all the fonts it needs to display 
correctly. These embedded fonts describe the way in which each character is 
drawn.

Typically there will be some characters in a font that are not used in a 
document. In this case, a font-subset may be embedded to help reduce the 
size of the PDF.

A PDF may also simply name the fonts it needs rather than include them. 
Provided the viewer’s computer has the named fonts installed, the PDF will 
display correctly. If not, the viewer program will try to use a substitute font 
that is similar in appearance.

Certain fonts are always available on every computer that can view PDFs. 
These are Courier, Times, Helvetica and Symbol. Consequently these fonts 
are not commonly embedded.

Font Considerations When Editing

Editing text written with a font that is embedded does not normally present 
any problems - all of the font’s characters are available.

When just a subset of a font is embedded, Infix will search for the required 
font within your computer’s system fonts and will automatically load and 
use it if found.

If no match can be found, you will have to use a different font instead.

For example, a document that contains a single headline written in the font 
“Marker Felt-Wide”:

may include character definitions for the following letters only:
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Custom Spelling Dictionaries
When you press the Add button during spell check, Infix records the word 
you are adding in a custom dictionary file on disc. 

If you add a word by mistake you can edit the custom dictionary by hand 
using any standard text editor (such as Notepad).

If you already have a custom dictionary you want Infix to use you can add its 
contents to Infix’s existing dictionary using a text editor.

Locating The Custom Dictionary

Go to the folder on your hard in which you installed Infix - this may be the 
same as the default- c:/Programs/Iceni/Infix

There you will find a folder caller spell check inside which is pers. The custom 
dictionary file is in pers and is called en.pws.

In summary, in a default installation the full path name to the dictionary is- 
c:/Programs/Iceni/Infix/spell check/pers/en.pws

Format of Custom Dictionary

The dictionary file is a simple list of words, each on a new line. The very first 
line of the file must contain the following: 
 personal_ws-1.1 en 4

This line is used by the spell check to identify the file and must be present.

An example dictionary file is shown below: 
 personal_ws-1.1 en 4 
 VPN 
 PPTP 
 dialog 
 SPAP

Changes to the custom dictionary will take effect the next time Infix is 
launched.
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